hacker emblem
jaegerfesting
Search | Tags | Photos | Flights | Gas Mileage | Log in

VMware vs iPod

Started: 2006-10-14 19:32:11

Submitted: 2006-10-14 20:14:25

Visibility: World-readable

For those of you visiting via Google, who no doubt already know that VMware 5.x explicitly doesn't support USB 2, which makes using iPods difficult, I have a victory to report: On a 2 gig (first-generation) iPod Nano, firmware version 1.1 fails horribly but firmware version 1.2 works great. This only took me all Saturday afternoon to figure out. The rest of this page is just narrative.


Kiesa's personal notebook Blue Kiesa never really worked perfectly. It shipped with a crippled version of XP Home with a Toshiba shrink-wrap license forbidding us from rejecting the Windows license and demanding a piecemeal refund. Kiesa didn't want to use XP Home (especially since we couldn't dual-boot without hassle), so she nuked XP Home, installed her copy of Windows 2000, and dual-booted with Linux. This worked well enough for a while, but Blue tended to have overheat, which caused all sorts of exciting stability problems. Last month she gave up entirely. Part of the problem seemed to be that we couldn't find the correct chipset drivers for Blue for Windows 2000, which should have been able to control frequency scaling to mitigate overheating. I hypothesized that I might be able to run Windows inside VMware Player, providing full access to iTunes and the audio books Kiesa downloads, while using the frequency-scaling support within the Linux kernel.

This seemed to work well. (My employer was kind enough to provide me a copy of VMware Workstation, so I could create the virtual machine and transfer it to Blue.) This afternoon I finally got around to installing iTunes and plugging in Kiesa's two-gig first-generation Nano and seeing what happened. All was not well: VMware Player detected the iPod as soon as I plugged it in and made it available to Guest Windows, which installed drivers and demanded to be rebooted. Upon reboot, nothing happened; I checked Device Manager, which reported a mysterious error and refused to do anything useful. I asked Google for help, which led me to a plethora of forum posts; I learned that VMware 5.x explicitly doesn't support USB 2, and VMware won't make any statements regarding the future availability of USB 2. I tried various combinations of things, including copying the virtual machine to Illyria (my notebook) with only USB 1.1, and plugging in my ten-gig third-generation iPod (which seemed to work fine, although I didn't let it get carried away because my iPod is Mac-formatted because I use it on my Mac Mini). In desperation, I remembered that iTunes tried to upgrade the Nano's firmware when it first tried to connect. I rebooted my notebook to Windows (which was the last iTunes install the Nano was connected to) and let it upgrade the firmware, then plugged the Nano into the virtual machine... and it magically worked.

Sometimes I'm lucky, sometimes I'm good, and sometimes I can't tell which. This time, though, was pure luck. (And several hours beating my head against my keyboard trying to figure out WTF was going on.)

When ignorance is bliss
Won't you save me from myself?
- Jars of Clay, "Fade to Grey"